Company of Heroes: Eastern Front

Author Topic: Launcher problem, says MOD is not installed on system  (Read 1332 times)

Offline ukyo24

  • Ingenery
  • *
  • Posts: 4
    • View Profile
Launcher problem, says MOD is not installed on system
« on: September 04, 2011, 02:13:14 AM »
Hello,

After thoroughly reading the FAQ and tech issues I failed to find a solution to the trouble I am having right now:

I am using the steam version of COH, (OF and TOV, all Steam).

Therefore I choose the Steam path for my installation however once the Launcher is run for the first time after setup I get the error shown on err1.jpg.

When I go to options to indicate my CoH folder I see cohdir1.jpg.

I choose my CoH folder as shown in cohdir2.jpg

And finally when I say PLAY on the launcher I get the error on err2.jpg

I have also uploaded EF_launcher.log file as well. The message 'Unable to locate Eastern Front Mod registry entries.' may mean something maybe?? :(

I have run my CoH,OF and ToV purchased from steam as suggested, tried running the Launcher with admin rights, and even tried the registry trick (InstallLocation, I can send a screen of it to if u like) suggested by Ritz. None has worked.  :'(

So please help me out. I have an x64, win7 system. My CoH version is 2.602 since the day it was released.

Thank you in advance.
« Last Edit: September 04, 2011, 02:21:16 AM by ukyo24 »

Offline Enrique 'Blackbishop' E.

  • Administrator
  • Poster of the Soviet Union
  • *
  • Posts: 12057
  • Community Manager, Programmer and Kicker
    • View Profile
Re: Launcher problem, says MOD is not installed on system
« Reply #1 on: September 04, 2011, 03:22:25 AM »
You need to run CoH(from Steam ofc) at least once in order to setup the necessary registries.
Mors Indecepta

Might controls everything, and without strength you cannot protect anything. Let alone yourself...

Offline ukyo24

  • Ingenery
  • *
  • Posts: 4
    • View Profile
Re: Launcher problem, says MOD is not installed on system
« Reply #2 on: September 04, 2011, 06:25:34 AM »
I have done that before I posted my question (I did mention it in my post as well), and it did not work. :(

Offline Enrique 'Blackbishop' E.

  • Administrator
  • Poster of the Soviet Union
  • *
  • Posts: 12057
  • Community Manager, Programmer and Kicker
    • View Profile
Re: Launcher problem, says MOD is not installed on system
« Reply #3 on: September 04, 2011, 06:52:12 AM »
Try this adding this registry entry.
Mors Indecepta

Might controls everything, and without strength you cannot protect anything. Let alone yourself...

Offline ukyo24

  • Ingenery
  • *
  • Posts: 4
    • View Profile
Re: Launcher problem, says MOD is not installed on system
« Reply #4 on: September 04, 2011, 07:33:53 AM »
After I applied the fix when I started the setup the installer recognized the below place for coh (As intended I guess):

C:\Program Files (x86)\Steam\SteamApps\common\company of heroes\

Nevertheless I installed.. and it did not work.

However my steam folder is elsewhere and this is my CoH location:

C:\Program1\Steam\steamapps\common\company of heroes\

Thus I edited your fix with this value.. but it didnt work..

Then I noticed that the address you provided and my actual location differ in 2 capital letters: steamapps

I edited the fix yet again, uninstalled and installed.. and no.. it again did not work and I probably messed up my registry as well :(

« Last Edit: September 04, 2011, 08:49:00 AM by ukyo24 »

Offline Enrique 'Blackbishop' E.

  • Administrator
  • Poster of the Soviet Union
  • *
  • Posts: 12057
  • Community Manager, Programmer and Kicker
    • View Profile
Re: Launcher problem, says MOD is not installed on system
« Reply #5 on: September 04, 2011, 08:09:15 PM »
As you have 64 bits OS your Program Files dir is Program Files (x86), steam doesn't have a 64 bits app, hence is installed in the latter.

For that registry entry value, it doesn't matter if differs in some capital letters, my path also has the same structure than yours and the installlocation value has zero capital letters and still works.

Sometimes the launcher refuses to work, even if the entries are there, don't know why this happens. You can try creating a shorcut to avoid using the launcher:

http://easternfront.org/forums/index.php?topic=5312.0
Mors Indecepta

Might controls everything, and without strength you cannot protect anything. Let alone yourself...

Offline ukyo24

  • Ingenery
  • *
  • Posts: 4
    • View Profile
Re: Launcher problem, says MOD is not installed on system
« Reply #6 on: September 05, 2011, 05:31:34 AM »
Yes! Finally :D That did it! Thank you so much!

I wish I knew this sooner. Maybe you admins might put a link on the FAQ page to this solution saying "if the launcher fails totally"?

Thank you blackbishop for the quick reply and all the effort to get this lowly Ingenery on to the battle field ;)

Keep up the good work guys, EF is great! :)